summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 13:50:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 13:50:26 +0200
commit192c7229284b9499257b6b4ac46a17b93ffd0c52 (patch)
treeaa56c2df986e644c4d60872a3b416c00bbb50432 /gnu/packages/python-web.scm
parent1aaeff86501cd38cb903f3c6c2b288f652c3bd5d (diff)
downloadguix-patches-192c7229284b9499257b6b4ac46a17b93ffd0c52.tar
guix-patches-192c7229284b9499257b6b4ac46a17b93ffd0c52.tar.gz
gnu: Add python-smart-open.
* gnu/packages/python-web.scm (python-smart-open): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f3cd3e521b..b4a2bc365b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6961,6 +6961,49 @@ via direct download. This package provides a Google Cloud Storage API client
library for Python.")
(license license:asl2.0)))
+(define-public python-smart-open
+ (package
+ (name "python-smart-open")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "smart_open" version))
+ (sha256
+ (base32 "1c12ilanx9hgpcc5chjkaqnx1hx14iazyindy7syvjhbdywhc0fn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #false ;none included
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs
+ (list python-azure-common
+ python-azure-core
+ python-azure-storage-blob
+ python-boto3
+ python-google-cloud-storage
+ python-requests))
+ (native-inputs
+ (list python-flask
+ python-flask-cors
+ python-graphql-core
+ python-moto
+ python-paramiko
+ python-pathlib2
+ python-pytest
+ python-pytest-rerunfailures
+ python-responses))
+ (home-page "https://github.com/piskvorky/smart_open")
+ (synopsis "Utilities for streaming large files")
+ (description
+ "This package provides utilities for streaming large files (S3, HDFS,
+GCS, Azure Blob Storage, gzip, bz2, etc.)")
+ (license license:expat)))
+
(define-public python-w3lib
(package
(name "python-w3lib")