summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 13:24:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 13:24:02 +0200
commit0873ab4d54f169c32d04cc2a2df92426e748f546 (patch)
tree322b39602d130b0eba76dd30b4ddce7f5d33a0aa /gnu/packages/python-web.scm
parent359e2db4b2543425ca526162264d60a08cd2e368 (diff)
downloadguix-patches-0873ab4d54f169c32d04cc2a2df92426e748f546.tar
guix-patches-0873ab4d54f169c32d04cc2a2df92426e748f546.tar.gz
gnu: Add python-google-resumable-media.
* gnu/packages/python-web.scm (python-google-resumable-media): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 46e7e28615..7f50ede8bf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6793,6 +6793,38 @@ of the CRC32C hashing algorithm.")
server-to-server authentication mechanisms to access Google APIs.")
(license license:asl2.0)))
+(define-public python-google-resumable-media
+ (package
+ (name "python-google-resumable-media")
+ (version "2.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "google-resumable-media" version))
+ (sha256
+ (base32 "04qm6rd4mpbbym8ci5xrb6fymc3mmm8x2z9f43q5iwbr3s5lx4h6"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The system tests fail to find test_utils.retry.
+ (delete-file-recursively "tests/system/")
+ (invoke "pytest")))))))
+ (propagated-inputs (list python-google-crc32c))
+ (native-inputs
+ (list python-google-auth
+ python-pytest
+ python-requests
+ python-test-utils))
+ (home-page "https://github.com/googleapis/google-resumable-media-python")
+ (synopsis "Utilities for Google Media Downloads and Resumable Uploads")
+ (description "This package provides utilities for Google Media Downloads
+and Resumable Uploads.")
+ (license license:asl2.0)))
+
(define-public python-googleapis-common-protos
(package
(name "python-googleapis-common-protos")