summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-16 17:07:25 -0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-17 07:52:44 +0300
commite87b063f4c36ee07c70aa8e9cda60f609675804e (patch)
tree97daabaf491e712159448a4fb6c013a6eb311d12 /gnu/packages/python-web.scm
parent3ede1e4d69121c29fcd2bb16281f013ad17bf109 (diff)
downloadguix-patches-e87b063f4c36ee07c70aa8e9cda60f609675804e.tar
guix-patches-e87b063f4c36ee07c70aa8e9cda60f609675804e.tar.gz
gnu: Add python-priority.
* gnu/packages/python-web.scm (python-priority): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f05658555a..c68609fa5d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -996,6 +996,38 @@ teams extension for python-openid.")
(define-public python2-openid-teams
(package-with-python2 python-openid-teams))
+(define-public python-priority
+ (package
+ (name "python-priority")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "priority" version))
+ (sha256
+ (base32 "1gpzn9k9zgks0iw5wdmad9b4dry8haiz2sbp6gycpjkzdld9dhbb"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "test" "-k"
+ ;; This test exceeded the Hypothesis deadline.
+ "not test_period_of_repetition"))))))
+ (native-inputs
+ `(("python-hypothesis" ,python-hypothesis)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-xdist" ,python-pytest-xdist)))
+ (home-page "https://python-hyper.org/projects/priority/en/latest/")
+ (synopsis "Pure-Python implementation of the HTTP/2 priority tree")
+ (description
+ "Priority is a pure-Python implementation of the priority logic for HTTP/2,
+set out in RFC 7540 Section 5.3 (Stream Priority).")
+ (license license:expat)))
+
(define-public python-wsproto
(package
(name "python-wsproto")