summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-16 17:07:24 -0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-17 07:46:41 +0300
commit3ede1e4d69121c29fcd2bb16281f013ad17bf109 (patch)
tree9bb74ea4aba2d367b5d29957147ec03c8ce04104 /gnu/packages/python-web.scm
parentfc9be8db2dacc73f46cf380e2b9a9c492386036f (diff)
downloadguix-patches-3ede1e4d69121c29fcd2bb16281f013ad17bf109.tar
guix-patches-3ede1e4d69121c29fcd2bb16281f013ad17bf109.tar.gz
gnu: Add python-wsproto.
* gnu/packages/python-web.scm (python-wsproto): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 957c5ceeff..f05658555a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -996,6 +996,37 @@ teams extension for python-openid.")
(define-public python2-openid-teams
(package-with-python2 python-openid-teams))
+(define-public python-wsproto
+ (package
+ (name "python-wsproto")
+ (version "0.15.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "wsproto" version))
+ (sha256
+ (base32 "17gsxlli4w8am1wwwl3k90hpdfa213ax40ycbbvb7hjx1v1rhiv1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "test"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-h11" ,python-h11)))
+ (home-page "https://github.com/python-hyper/wsproto/")
+ (synopsis "WebSockets state-machine based protocol implementation")
+ (description
+ "@code{wsproto} is a pure-Python implementation of a WebSocket protocol
+stack. It's written from the ground up to be embeddable in whatever program you
+choose to use, ensuring that you can communicate via WebSockets, as defined in
+RFC6455, regardless of your programming paradigm.")
+ (license license:expat)))
+
(define-public python-tornado
(package
(name "python-tornado")