summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-08 17:12:46 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 21:20:01 +0200
commita5a90a98d8664c92bb8d744abfde6c68c342d364 (patch)
tree7fe369f0e95fef2c097d6e213159eeea983808e4 /gnu/packages/python-web.scm
parentd0b3bb9df7dd04449d7d9a4d0e7f4b67b255a3e6 (diff)
downloadguix-patches-a5a90a98d8664c92bb8d744abfde6c68c342d364.tar
guix-patches-a5a90a98d8664c92bb8d744abfde6c68c342d364.tar.gz
gnu: python-hyperframe: Respect "--without-tests".
* gnu/packages/python-web.scm (python-hyperframe)[arguments]<#:phases>{check}: Respect #:tests?. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 656f310dc1..cdc5c13b09 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -843,9 +844,10 @@ follow links and submit forms. It doesn’t do JavaScript.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "test"))))))
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "test")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://github.com/python-hyper/hyperframe")