summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-02 00:38:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:33 -0400
commit77afe03cf9e90f597571b4181f620da0997e84af (patch)
tree39c356de10a9aa6cfe4a2173eee5c22bb85f86ff /gnu/packages/python-web.scm
parenteb1b193379ee23b43ef7a3bb90d718df5c6c7d24 (diff)
downloadguix-patches-77afe03cf9e90f597571b4181f620da0997e84af.tar
guix-patches-77afe03cf9e90f597571b4181f620da0997e84af.tar.gz
gnu: Add python-jstyleson.
* gnu/packages/python-web.scm (python-jstyleson): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7feac5955f..cb52db3bbd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7368,3 +7368,22 @@ scraping framework, used to crawl websites and extract structured data
from their pages. It can be used for a wide range of purposes, from data
mining to monitoring and automated testing.")
(license license:bsd-3)))
+
+(define-public python-jstyleson
+ (package
+ (name "python-jstyleson")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jstyleson" version))
+ (sha256
+ (base32 "13ihw6jqwkg3ai4xb83kw39pvh73b2wg6ld3wvj5jaasn7rh6038"))))
+ (build-system python-build-system)
+ (arguments (list #:tests? #f)) ;no tests in pypi release
+ (home-page "https://github.com/linjackson78/jstyleson")
+ (synopsis "JSON parser supporting js-style comments")
+ (description "@code{jstyleson} is a Python library to parse JSON.
+Contrary to the standard Python @code{json} library, it understands js-style
+comments. Trailing comma is also supported.")
+ (license license:expat)))