summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 02:47:04 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:47 -0400
commit7720afd99ae389cca36bca51abe7ba6b500fb190 (patch)
tree0b78173fec4821d3de2b2e4a655e1d8b2bc108fd /gnu/packages/python-web.scm
parent2d51db54bd9abafd7777012e94e8f4c21dff8aa1 (diff)
downloadguix-patches-7720afd99ae389cca36bca51abe7ba6b500fb190.tar
guix-patches-7720afd99ae389cca36bca51abe7ba6b500fb190.tar.gz
gnu: Remove python2-requests.
* gnu/packages/python-web.scm (python2-requests): Delete variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f4302e0108..398f2891dd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2723,17 +2723,7 @@ APIs.")
(description
"Requests is a Python HTTP client library. It aims to be easier to use
than Python’s urllib2 library.")
- (license license:asl2.0)
- (properties `((python2-variant . ,(delay python2-requests))))))
-
-(define-public python2-requests
- (let ((base (package-with-python2 (strip-python2-variant python-requests))))
- (package
- (inherit base)
- ;; The python-charset-normalizer dependency is necessary on Python 3
- ;; only.
- (propagated-inputs (modify-inputs (package-propagated-inputs base)
- (delete "python-charset-normalizer"))))))
+ (license license:asl2.0)))
(define-public python-requests-unixsocket
(package