summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 13:21:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 13:21:54 +0200
commit359e2db4b2543425ca526162264d60a08cd2e368 (patch)
tree3ca65a4a5a2966fb457242a7dd6bc0ebbeadeb06 /gnu/packages/python-web.scm
parentc63164188fc893c9500c4c953c808d24c12b6894 (diff)
downloadguix-patches-359e2db4b2543425ca526162264d60a08cd2e368.tar
guix-patches-359e2db4b2543425ca526162264d60a08cd2e368.tar.gz
gnu: Add python-google-auth.
* gnu/packages/python-web.scm (python-google-auth): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 51e03ed56f..46e7e28615 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6753,6 +6753,46 @@ Client Library for Python.")
of the CRC32C hashing algorithm.")
(license license:asl2.0)))
+(define-public python-google-auth
+ (package
+ (name "python-google-auth")
+ (version "2.6.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "google-auth" version))
+ (sha256
+ (base32 "04ikassansqkkw4pa98in7q9r4z001m6bi2r3ssxwwrb0f79790v"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs
+ (list python-cachetools
+ python-cryptography
+ python-pyasn1-modules
+ python-rsa
+ python-six))
+ (native-inputs
+ (list python-flask
+ python-freezegun
+ python-oauth2client
+ python-pyopenssl
+ python-pytest
+ python-pytest-localserver
+ python-pyu2f
+ python-requests
+ python-responses))
+ (home-page "https://github.com/googleapis/google-auth-library-python")
+ (synopsis "Google Authentication Library")
+ (description "This library simplifies using Google's various
+server-to-server authentication mechanisms to access Google APIs.")
+ (license license:asl2.0)))
+
(define-public python-googleapis-common-protos
(package
(name "python-googleapis-common-protos")