summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 00:07:48 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:51 -0400
commitf17611f3bef3ee28a88b53a74e6e84bcfdbed966 (patch)
tree6d1d9bd02eea4d4ea446c4968d19f824ca928e73 /gnu/packages/python-web.scm
parentc5d5c14101535b0a44ccb5fdfb72fad265702a8b (diff)
downloadguix-patches-f17611f3bef3ee28a88b53a74e6e84bcfdbed966.tar
guix-patches-f17611f3bef3ee28a88b53a74e6e84bcfdbed966.tar.gz
gnu: python-httpcore: Update to 0.14.7 and enable tests.
* gnu/packages/python-web.scm (python-httpcore): Update to 0.14.7. [tests?]: Delete argument. [phases]{check}: Streamline and delete coverage related pytest options. Strip trailing #t. [native-inputs]: Delete python-autoflake, python-flake8, python-flake8-bugbear, python-flake8-pie and python-mypy. Add python-pytest-httpbin. [propagated-inputs]: Add python-anyio, python-certifi and python-socksio.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 14 insertions, 17 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 36d7fb03f9..d658985520 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5254,7 +5254,7 @@ and serve updated contents upon changes to the directory.")
(define-public python-httpcore
(package
(name "python-httpcore")
- (version "0.12.2")
+ (version "0.14.7")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -5264,34 +5264,31 @@ and serve updated contents upon changes to the directory.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1nrwwfdqjfc2a1k3j41cdwkprwvplf95fwmypdl2aq2qgp3209q0"))))
+ (base32 "0wdr28vf03l6yxhk8nrvhh7y7x18rqdcfzv1sb6jgzk9zmycrvc7"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; Tests hang at 98%
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "--cov=httpcore"
- "--cov=tests" "tests"))
- #t)))))
+ (invoke "pytest" "-vv" "tests")))))))
(native-inputs
- (list python-autoflake
- python-flake8
- python-flake8-bugbear
- python-flake8-pie
- python-isort
- python-mypy
- python-pytest
+ (list python-pytest
python-pytest-asyncio
python-pytest-cov
+ python-pytest-httpbin
python-pytest-trio
python-uvicorn
python-trustme))
(propagated-inputs
- (list python-h11 python-h2 python-sniffio python-trio
+ (list python-anyio
+ python-certifi
+ python-h11
+ python-h2
+ python-sniffio
+ python-socksio
+ python-trio
python-trio-typing))
(home-page "https://github.com/encode/httpcore")
(synopsis "Minimal, low-level HTTP client")