summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-17 08:07:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:50 -0400
commit37caa64189b1cd35a806d42fcc9cad7001388164 (patch)
treeafb03e354d2013e84b15c97f1360e2b162bb7340 /gnu/packages/python-web.scm
parent2576d9ffc4c5cf84c4c6c1dfee2d2d8655fba4b4 (diff)
downloadguix-patches-37caa64189b1cd35a806d42fcc9cad7001388164.tar
guix-patches-37caa64189b1cd35a806d42fcc9cad7001388164.tar.gz
gnu: python-websockets: Update to 10.3 and enable tests.
* gnu/packages/python-web.scm (python-websockets): Fetch from git. Update to 10.3. [arguments]: Delete field, enabling tests.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 10 insertions, 16 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 340f84c78f..aaa45c5f4c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5345,24 +5345,18 @@ files.")
(define-public python-websockets
(package
(name "python-websockets")
- (version "8.1")
+ (version "10.3")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "websockets" version))
- (sha256
- (base32
- "03s3ml6sbki24aajllf8aily0xzrn929zxi84p50zkkbikdd4raw"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aaugustin/websockets")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vk7g5z977mi89hamwiqawpmibwvv9ghrf3pqva1waxmyc7gyjb5"))))
(build-system python-build-system)
- (arguments
- '(#:tests? #f ; Tests not included in release tarball.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-websockets-package-name-requirement
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Python package names use dot as separator.
- (substitute* "setup.py"
- (("websockets/extensions") "websockets.extensions")))))))
(home-page "https://github.com/aaugustin/websockets")
(synopsis
"Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")