summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-04-20 17:28:01 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-02 15:14:46 +0200
commitd219d48cce59e02195e32a80c16e0b7cffb11e75 (patch)
tree0f37a4227b6fce1f3ae1694d8b182c93ecd4201a /gnu/packages/python-web.scm
parentc0c16d6b8472563acf895578a3ebfeeb75b29fec (diff)
downloadguix-patches-d219d48cce59e02195e32a80c16e0b7cffb11e75.tar
guix-patches-d219d48cce59e02195e32a80c16e0b7cffb11e75.tar.gz
gnu: Add python-protego.
* gnu/packages/python-web.scm (python-protego): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7e333916b6..05104f8fe2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6466,3 +6466,30 @@ as Flask.")
"This package provides a Python JSON-RPC 2.0 protocol and server powered
by asyncio.")
(license license:expat)))
+
+(define-public python-protego
+ (package
+ (name "python-protego")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Protego" version))
+ (sha256
+ (base32 "1wigcjyhz8zbk562zhgfbkm733dcn65j1swzvki79dys0i1nsrnz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs (list python-six))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/scrapy/protego")
+ (synopsis
+ "Pure-Python robots.txt parser with support for modern conventions")
+ (description
+ "Pure-Python robots.txt parser with support for modern conventions.")
+ (license license:bsd-3)))