summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-04-20 17:28:02 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-02 15:14:46 +0200
commit76b6337650ba35c85e9263c958dd334766268172 (patch)
tree7bdf51b0be508ab0ba31b7ef00065a54abce940d /gnu/packages/python-web.scm
parentd219d48cce59e02195e32a80c16e0b7cffb11e75 (diff)
downloadguix-patches-76b6337650ba35c85e9263c958dd334766268172.tar
guix-patches-76b6337650ba35c85e9263c958dd334766268172.tar.gz
gnu: Add python-parsel.
* gnu/packages/python-web.scm (python-parsel): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 05104f8fe2..b2fbbc86cd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6493,3 +6493,28 @@ by asyncio.")
(description
"Pure-Python robots.txt parser with support for modern conventions.")
(license license:bsd-3)))
+
+(define-public python-parsel
+ (package
+ (name "python-parsel")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "parsel" version))
+ (sha256
+ (base32 "0yawf9r3r863lwxj0n89i7h3n8xjbsl5b7n6xg76r68scl5yzvvh"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-cssselect
+ python-lxml
+ python-six
+ python-w3lib))
+ (native-inputs
+ (list python-pytest python-pytest-runner))
+ (home-page "https://github.com/scrapy/parsel")
+ (synopsis "Extract data from HTML and XML using XPath and CSS selectors")
+ (description "Parsel is a library to extract and remove data from
+HTML and XML using XPath and CSS selectors, optionally combined with
+regular expressions.")
+ (license license:bsd-3)))