summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-01 00:57:54 +0100
committerMarius Bakke <marius@gnu.org>2021-12-05 14:02:09 +0100
commit846bd3d083eaf5e243367245daeaef0d0a0b65ce (patch)
tree8576249ef044899dec0143a4a0649168c9c4c8eb /gnu/packages/python-web.scm
parent9f5b9d18d88be838739f8fd1f1c4e84446f8fc53 (diff)
downloadguix-patches-846bd3d083eaf5e243367245daeaef0d0a0b65ce.tar
guix-patches-846bd3d083eaf5e243367245daeaef0d0a0b65ce.tar.gz
gnu: python-webassets: Patch for Python 3.9.
* gnu/packages/python-web.scm (python-webassets)[arguments]: Add substitution.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 98e3e6a8d5..811650de24 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3762,8 +3762,12 @@ for Flask.")
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'check 'disable-some-tests
+ (add-before 'check 'adjust-tests
(lambda _
+ ;; Fix for Python 3.9 compatibility.
+ (substitute* "tests/test_script.py"
+ (("self\\.t\\.isAlive")
+ "self.t.is_alive"))
;; This test requires 'postcss' and 'babel' which are
;; not yet available in Guix.
(delete-file "tests/test_filters.py")))