summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-27 11:13:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-27 12:48:40 +0200
commitc5e110ce95949b128a9b7cbc0b79ac7f616b400d (patch)
tree01ac3455b7e6e606e51a0f92c6ee25cac37709b7 /gnu/packages/python-web.scm
parent8d7e7ca6a1c801aa636cfc1767b8839fef77c97e (diff)
downloadguix-patches-c5e110ce95949b128a9b7cbc0b79ac7f616b400d.tar
guix-patches-c5e110ce95949b128a9b7cbc0b79ac7f616b400d.tar.gz
gnu: python-werkzeug: Update to 0.14.1.
* gnu/packages/python-web.scm (python-werkzeug): Update to 0.14.1. [arguments]: Run tests after 'install phase. Use custom 'check phase. [propagated-inputs]: Add python-requests. [home-page]: Update to new home-page.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cee4973086..9522abbdf3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2603,18 +2603,28 @@ List. Forked from and using the same API as the publicsuffix package.")
(define-public python-werkzeug
(package
(name "python-werkzeug")
- (version "0.11.15")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Werkzeug" version))
+ (uri (pypi-uri "werkzeug" version))
(sha256
(base32
- "1h5wycw8yj7q0grqsjnsqflmrlsdagvl2j4dsgdncci6mjc7fpa5"))))
+ "0z2m4snn1vc9518r2vzgdj1nc90kcgi60wijvd29yvcp85ypmzf3"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest"))))))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
(native-inputs
`(("python-pytest" ,python-pytest)))
- (home-page "http://werkzeug.pocoo.org/")
+ (home-page "https://www.palletsprojects.org/p/werkzeug/")
(synopsis "Utilities for WSGI applications")
(description "One of the most advanced WSGI utility modules. It includes a
powerful debugger, full-featured request and response objects, HTTP utilities to