summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-11 10:41:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-11 11:13:56 +0200
commit95176544d54cbc8c7c2bacd96e19b4a1411afbff (patch)
tree9b9267c0b9412c8fc2c73675ed25f10e2c97e382 /gnu/packages/python-web.scm
parent5ac2b2717f8d4b05c39c5717843d40bb1a493364 (diff)
downloadguix-patches-95176544d54cbc8c7c2bacd96e19b4a1411afbff.tar
guix-patches-95176544d54cbc8c7c2bacd96e19b4a1411afbff.tar.gz
gnu: python-paste: Update to 3.0.4.
* gnu/packages/python-web.scm (python-paste): Update to 3.0.4. [source]: Remove patch, add snippet to remove one test. [native-inputs]: Add python-pytest, python-pytest-runner. * gnu/packages/patches/python-paste-remove-website-test.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6a8b1f21fb..e158df2000 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
@@ -2628,19 +2628,25 @@ available in Django, but is a standalone package.")
(define-public python-paste
(package
(name "python-paste")
- (version "2.0.3")
+ (version "3.0.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Paste" version))
(sha256
(base32
- "062jk0nlxf6lb2wwj6zc20rlvrwsnikpkh90y0dn8cjch93s6ii3"))
- (patches (search-patches "python-paste-remove-website-test.patch"
- "python-paste-remove-timing-test.patch"))))
+ "01w26w9jyfkh0mfydhfz3dwy3pj3fw7mzvj0lna3vs8hyx1hwl0n"))
+ (patches (search-patches "python-paste-remove-timing-test.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This test calls out to the internet.
+ (delete-file "tests/test_proxy.py") #t))))
(build-system python-build-system)
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-nose" ,python-nose)))
(propagated-inputs
`(("python-six" ,python-six)))
(home-page "http://pythonpaste.org")