summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:14:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:14:08 +0300
commit256e8a82fa98f63a1416a283de86a32b074e7f7b (patch)
tree62b44b5587af0cb3d71318c09b53844b03ec5007 /gnu/packages/python-web.scm
parent2ed6491f9c07c06537ed43db12e23c829da96622 (diff)
downloadguix-patches-256e8a82fa98f63a1416a283de86a32b074e7f7b.tar
guix-patches-256e8a82fa98f63a1416a283de86a32b074e7f7b.tar.gz
gnu: python-zope-component: Update to 4.6.2.
* gnu/packages/python-web.scm (python-zope-component): Update to 4.6.2. [arguments]: Run test suite. Use custom 'check phase. [native-inputs]: Add python-persistent, python-zope-configuration-bootstrap, python-zope-i18nmessageid, python-zope-location-bootstrap, python-zope-proxy-bootstrap, python-zope-testrunner. [propagated-inputs]: Move python-i18nmessageid to native-inputs. Add python-zope-deferredimport, python-zope-deprecation, python-zope-event, python-zope-hookable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm30
1 files changed, 21 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 77a6e95737..4e3387f21e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1456,25 +1456,37 @@ security policies on Python objects.")
(define-public python-zope-component
(package
(name "python-zope-component")
- (version "4.3.0")
+ (version "4.6.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "zope.component" version))
(sha256
(base32
- "1hlvzwj1kcfz1qms1dzhwsshpsf38z9clmyksb1gh41n8k3kchdv"))))
+ "14iwp95hh6q5dj4k9h1iw75cbp89bs27nany4dinyglb44c8jqli"))))
(build-system python-build-system)
(arguments
- ;; Skip tests due to circular dependency with python-zope-security.
- '(#:tests? #f))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "setup.py" "test"))))))
(native-inputs
- `(("python-zope-testing" ,python-zope-testing)))
- (propagated-inputs
- `(("python-zope-event" ,python-zope-event)
- ("python-zope-interface" ,python-zope-interface)
+ `(("python-persistent" ,python-persistent)
+ ("python-zope-configuration" ,python-zope-configuration-bootstrap)
("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
- ("python-zope-configuration" ,python-zope-configuration)))
+ ("python-zope-location" ,python-zope-location-bootstrap)
+ ("python-zope-proxy" ,python-zope-proxy-bootstrap)
+ ("python-zope-security" ,python-zope-security-bootstrap)
+ ("python-zope-testing" ,python-zope-testing)
+ ("python-zope-testrunner" ,python-zope-testrunner)))
+ (propagated-inputs
+ `(("python-zope-deferredimport" ,python-zope-deferredimport)
+ ("python-zope-deprecation" ,python-zope-deprecation)
+ ("python-zope-event" ,python-zope-event)
+ ("python-zope-hookable" ,python-zope-hookable)
+ ("python-zope-interface" ,python-zope-interface)))
(home-page "https://github.com/zopefoundation/zope.component")
(synopsis "Zope Component Architecture")
(description "Zope.component represents the core of the Zope Component