summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-11-12 16:42:41 +0100
committerMarius Bakke <marius@gnu.org>2021-11-15 00:25:06 +0100
commite5b53b1e828d7838c4162b76e118e8ec238d4309 (patch)
treea643d9488135f886477981e54b1749b0b17b8408 /gnu/packages/python-web.scm
parentd67a5a8a490e58bc645793128a25d642ccb96e83 (diff)
downloadguix-patches-e5b53b1e828d7838c4162b76e118e8ec238d4309.tar
guix-patches-e5b53b1e828d7838c4162b76e118e8ec238d4309.tar.gz
gnu: python-uritemplate: Update to 4.1.1.
* gnu/packages/python-web.scm (python-uritemplate): Update to 4.1.1. [license]: Add LICENSE:ASL2.0. (python2-uritemplate): Remove variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 59e8145cef..690c85b1ab 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4044,23 +4044,23 @@ authentication for Flask routes.")
(define-public python-uritemplate
(package
(name "python-uritemplate")
- (version "3.0.1")
+ (version "4.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "uritemplate" version))
(sha256
(base32
- "1bkwmgr0ia9gcn4bszs2xlvml79f0bi2s4a87xg22ky9rq8avy2s"))))
+ "1w14a775d92mx9pdhb5zimifpfr2lfcn0vfdpjagcy9vbkyfsij3"))))
(build-system python-build-system)
(home-page "https://uritemplate.readthedocs.org")
(synopsis "Library to deal with URI Templates")
(description "@code{uritemplate} provides Python library to deal with URI
Templates.")
- (license license:bsd-2)))
-
-(define-public python2-uritemplate
- (package-with-python2 python-uritemplate))
+ ;; The software is made available under the terms of *either* of the
+ ;; licenses found in LICENSE.APACHE or LICENSE.BSD. Contributions
+ ;; are made under *both* licenses (excerpt from the LICENSE file).
+ (license (list license:bsd-2 license:asl2.0))))
(define-public python-publicsuffix
(package