summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-29 18:45:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-30 16:46:17 +0100
commit16d7f26feda0e3f35f046f20bff0a2db7e13b98d (patch)
treee5eefd539313d89382974671d30e568bb1ef3899 /gnu/packages/python-web.scm
parentbfaf7b559e80d246ddfcbabbe8f6a100e1764aaf (diff)
downloadguix-patches-16d7f26feda0e3f35f046f20bff0a2db7e13b98d.tar
guix-patches-16d7f26feda0e3f35f046f20bff0a2db7e13b98d.tar.gz
gnu: Add python-woob.
* gnu/packages/python-web.scm (python-woob): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4ddf89c207..5d0cbda0cc 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -86,6 +86,7 @@
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages texinfo)
@@ -6310,6 +6311,48 @@ Only the RGB colorspace is supported. Conversion to/from the HSL colorspace
can be handled by the @code{colorsys} module in the Python standard library.")
(license license:bsd-3)))
+(define-public python-woob
+ (package
+ (name "python-woob")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "woob" version))
+ (sha256
+ (base32 "09hpxy5zhn2b8li0xjf3zd7s46lawb0315p5mdcsci3bj3s4v1j7"))))
+ (build-system python-build-system)
+ ;; A small number of tests for optional applications fails due to missing
+ ;; inputs.
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("python-babel" ,python-babel)
+ ("python-colorama" ,python-colorama)
+ ("python-cssselect" ,python-cssselect)
+ ("python-dateutil" ,python-dateutil)
+ ("python-feedparser" ,python-feedparser)
+ ("python-html2text" ,python-html2text)
+ ("python-lxml" ,python-lxml)
+ ("python-pillow" ,python-pillow)
+ ("python-prettytable" ,python-prettytable)
+ ("python-pyqt" ,python-pyqt)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests)
+ ("python-six" ,python-six)
+ ("python-unidecode" ,python-unidecode)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-flake8" ,python-flake8)
+ ("python-nose" ,python-nose)
+ ("python-selenium" ,python-selenium)
+ ("python-xunitparser" ,python-xunitparser)))
+ (home-page "https://woob.tech/")
+ (synopsis "Woob, Web Outside Of Browsers")
+ (description "Woob is a collection of applications able to interact with
+websites, without requiring the user to open them in a browser. It also
+provides well-defined APIs to talk to websites lacking one.")
+ (license license:lgpl3+)))
+
(define-public python-flask-combo-jsonapi
(package
(name "python-flask-combo-jsonapi")