summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-08-31 18:33:58 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-08-31 18:39:25 +0200
commitbac072e09bb80c172672e13782e1ed25ce04d6d5 (patch)
tree3b49cac3a37b67942a6fe8952dd6e614310bf989 /gnu/packages/python-web.scm
parentfaf6963a1dcf462e0d2fff95af0deb9479250403 (diff)
downloadguix-patches-bac072e09bb80c172672e13782e1ed25ce04d6d5.tar
guix-patches-bac072e09bb80c172672e13782e1ed25ce04d6d5.tar.gz
gnu: python-google-api-client: Rewrite invalid setup.py.
The packages argument accepts package names only, not paths. Replacing the slash with a dot allows passing the sanity-check phase, because the submodule will not be listed in top_level.txt any more. * gnu/packages/python-web.scm (python-google-api-client) [#:phases]: Add new phase 'fix-setup-py.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 91b68cf5f4..4763abce8b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4338,7 +4338,15 @@ Google search engine. Its module is called @code{googlesearch}.")
"1wpbbbxfpy9mwxdy3kn352cb590ladv574j1aa2l4grjdqw3ln05"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ; tests require internet access
+ `(#:tests? #f ; tests require internet access
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-setup-py
+ (lambda _
+ (substitute* "setup.py"
+ (("googleapiclient/discovery_cache")
+ "googleapiclient.discovery_cache"))
+ #t)))))
(native-inputs
`(("python-httplib2" ,python-httplib2)
("python-six" ,python-six)