summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-19 13:21:22 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-19 13:21:22 +0000
commit931fee88a92912928f0c6cb28d686e067645fa6c (patch)
tree20dc621d36102229dbb87eec7420ac59e07d7d58 /gnu/packages/python-web.scm
parent84f39130a5d9254d006df2bc2460711fa6116dee (diff)
downloadguix-patches-931fee88a92912928f0c6cb28d686e067645fa6c.tar
guix-patches-931fee88a92912928f0c6cb28d686e067645fa6c.tar.gz
gnu: python-s3transfer: Update to 0.5.0.
* gnu/packages/python-web.scm (python-s3transfer): Update to 0.5.0. [arguments]: Remove 'patch phase; remove trailing #t from 'check phase.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3da4853a5c..4e7c5d01da 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3356,32 +3356,22 @@ Betamax that may possibly end up in the main package.")
(define-public python-s3transfer
(package
(name "python-s3transfer")
- (version "0.3.3")
+ (version "0.5.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "s3transfer" version))
(sha256
(base32
- "1nzp5kwmy9669334shcz9ipg89jgpdqhrmbkgdg18r7wmvi3f6lj"))))
+ "0k6sc956yrrv9b4laa0r79jhxajpyxr21jcd1ka8m1n53lz85vah"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda _
- ;; There's a small issue with one test with Python 3.8, this
- ;; change has been suggested upstream:
- ;; https://github.com/boto/s3transfer/pull/164
- (substitute* "tests/unit/test_s3transfer.py"
- (("super\\(FailedDownloadParts, self\\)\\.submit\\(function\\)")
- "futures.Future()"))
- #t))
(replace 'check
(lambda _
;; Some of the 'integration' tests require network access or
;; login credentials.
- (invoke "nosetests" "--exclude=integration")
- #t)))))
+ (invoke "nosetests" "--exclude=integration"))))))
(native-inputs
`(("python-docutils" ,python-docutils)
("python-mock" ,python-mock)