summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-12 23:51:33 +0200
committerMarius Bakke <marius@gnu.org>2021-10-13 00:22:07 +0200
commit6c1724f6cd5636605e0aa1acbf6aadde41bd5004 (patch)
tree6a5bec15517bbab7e0c079f5f7dfe3e5cfc9a33d /gnu/packages/python-web.scm
parentb4b314cc53a19f640ceef99acb10880dbcc838b1 (diff)
downloadguix-patches-6c1724f6cd5636605e0aa1acbf6aadde41bd5004.tar
guix-patches-6c1724f6cd5636605e0aa1acbf6aadde41bd5004.tar.gz
gnu: python-zope-exceptions: Respect '--without-tests'.
* gnu/packages/python-web.scm (python-zope-exceptions)[arguments]: Honor TESTS? argument in check phase.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5335aa004c..e058b4ca50 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1920,8 +1920,10 @@ conforming to a given API or contract.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "zope-testrunner" "--test-path=src"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "zope-testrunner" "--test-path=src")
+ (format #t "test suite not run~%")))))))
(native-inputs
`(("python-zope-testrunner" ,python-zope-testrunner-bootstrap)))
(propagated-inputs