summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-13 23:48:31 +0200
committerMarius Bakke <marius@gnu.org>2020-07-14 21:29:13 +0200
commit97849d6762e1d0865b6a17133c841eb5421c44d3 (patch)
treea964f1185b1e7cdb63abe5be886e409a2ea38643 /gnu/packages/python-web.scm
parent906eaf8cf77ed35b4000966f2530def997ee2874 (diff)
downloadguix-patches-97849d6762e1d0865b6a17133c841eb5421c44d3.tar
guix-patches-97849d6762e1d0865b6a17133c841eb5421c44d3.tar.gz
gnu: python-urllib3: Remove unused input.
* gnu/packages/python-web.scm (python-urllib3)[propagated-inputs]: Remove PYTHON-IPADDRESS. [properties]: New field. (python2-urllib3)[propagated-inputs]: Add PYTHON2-IPADDRESS.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 030abef9c2..4b8a959570 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1691,7 +1691,6 @@ authenticated session objects providing things like keep-alive.")
("python-certifi" ,python-certifi)
("python-cryptography" ,python-cryptography)
("python-idna" ,python-idna)
- ("python-ipaddress" ,python-ipaddress)
("python-pyopenssl" ,python-pyopenssl)
("python-pysocks" ,python-pysocks)))
(home-page "https://urllib3.readthedocs.io/")
@@ -1700,6 +1699,7 @@ authenticated session objects providing things like keep-alive.")
"Urllib3 supports features left out of urllib and urllib2 libraries. It
can reuse the same socket connection for multiple requests, it can POST files,
supports url redirection and retries, and also gzip and deflate decoding.")
+ (properties `((python2-variant . ,(delay python2-urllib3))))
(license license:expat)))
;; Some software requires an older version of urllib3, notably Docker.
@@ -1715,7 +1715,12 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(define-public python2-urllib3
- (package-with-python2 python-urllib3))
+ (let ((base (package-with-python2 (strip-python2-variant python-urllib3))))
+ (package/inherit
+ base
+ (propagated-inputs
+ `(("python-ipaddress" ,python2-ipaddress)
+ ,@(package-propagated-inputs base))))))
(define-public awscli
(package