summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-21 15:38:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:45 -0500
commit08769d0bce8d1891b256c152835d4ae870d4491f (patch)
treea5766d49c1b2ab62e9979d89b37b95c965ebebce /gnu/packages/python-web.scm
parentf0be3ddadfeb8a25f372f4740b6ac5c7b9932a81 (diff)
downloadguix-patches-08769d0bce8d1891b256c152835d4ae870d4491f.tar
guix-patches-08769d0bce8d1891b256c152835d4ae870d4491f.tar.gz
gnu: python-requests-toolbelt: Update to 0.9.1 and enable tests.
* gnu/packages/python-web.scm (pyhton-requests-toolbelt): Update to 0.9.1. [phases]{delete-problematic-tests}: New phase. (python-requests-toolbelt-0.9.1): Delete variable. (python2-requests-toolbelt): Likewise. (python-cloudscraper): Adjust accordingly.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm36
1 files changed, 14 insertions, 22 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c8c793e30d..c714476aa8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -687,7 +687,7 @@ other HTTP libraries.")
'(#:tests? #f))
(propagated-inputs
(list python-colorama python-pygments python-requests
- python-requests-toolbelt-0.9.1))
+ python-requests-toolbelt))
(home-page "https://httpie.io")
(synopsis "cURL-like tool for humans")
(description
@@ -2597,14 +2597,23 @@ portions of your testing code.")
(define-public python-requests-toolbelt
(package
(name "python-requests-toolbelt")
- (version "0.8.0")
+ (version "0.9.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "requests-toolbelt" version))
(sha256
(base32
- "1dc7l42i4080r8i4m9fj51jx367lqkai170vrv7wd93gdj9k39gn"))))
+ "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'delete-problematic-tests
+ (lambda _
+ ;; Fails because of expired certificate.
+ (delete-file "tests/test_x509_adapter.py")
+ ;; Fails due to networking (socket.gaierror: [Errno -2]
+ ;; Name or service not known).
+ (delete-file "tests/test_multipart_encoder.py"))))))
(native-inputs
(list python-betamax python-mock python-pytest))
(propagated-inputs
@@ -2612,26 +2621,9 @@ portions of your testing code.")
(synopsis "Extensions to python-requests")
(description "This is a toolbelt of useful classes and functions to be used
with python-requests.")
- (home-page "https://github.com/sigmavirus24/requests-toolbelt")
+ (home-page "https://github.com/requests/toolbelt/")
(license license:asl2.0)))
-(define-public python2-requests-toolbelt
- (package-with-python2 python-requests-toolbelt))
-
-(define-public python-requests-toolbelt-0.9.1
- (package
- (inherit python-requests-toolbelt)
- (version "0.9.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "requests-toolbelt" version))
- (sha256
- (base32
- "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
- (arguments
- `(;; FIXME: Some tests require network access.
- #:tests? #f))))
-
(define-public python-requests-ftp
(package
(name "python-requests-ftp")
@@ -5865,7 +5857,7 @@ Encoding for HTTP.")
(list python-js2py
python-polling2
python-requests
- python-requests-toolbelt-0.9.1
+ python-requests-toolbelt
python-responses
python-pyparsing-2.4.7))
(native-inputs