summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-05 01:58:32 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-12 00:27:54 +0100
commit32135392dd6de8eebcbcf616d9d326ddaa359ab0 (patch)
tree7421ee2694e74eb952484f4fef4edab74639b201 /gnu/packages/python-web.scm
parentdbf5d938c54dbc0cf3271018a0a4aa5b69ec4037 (diff)
downloadguix-patches-32135392dd6de8eebcbcf616d9d326ddaa359ab0.tar
guix-patches-32135392dd6de8eebcbcf616d9d326ddaa359ab0.tar.gz
gnu: python-s3transfer: Update to 0.5.0.
* gnu/packages/python-web.scm (python-s3transfer): Update to 0.5.0. [arguments]<#:phases>: Remove 'patch phase because the issue was fixed upstream. Don't return #t in custom 'check phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 063b2c5e73..8ad43b8aa4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3414,32 +3414,22 @@ Betamax that may possibly end up in the main package.")
(define-public python-s3transfer
(package
(name "python-s3transfer")
- (version "0.3.3")
+ (version "0.5.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "s3transfer" version))
(sha256
(base32
- "1nzp5kwmy9669334shcz9ipg89jgpdqhrmbkgdg18r7wmvi3f6lj"))))
+ "0k6sc956yrrv9b4laa0r79jhxajpyxr21jcd1ka8m1n53lz85vah"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda _
- ;; There's a small issue with one test with Python 3.8, this
- ;; change has been suggested upstream:
- ;; https://github.com/boto/s3transfer/pull/164
- (substitute* "tests/unit/test_s3transfer.py"
- (("super\\(FailedDownloadParts, self\\)\\.submit\\(function\\)")
- "futures.Future()"))
- #t))
(replace 'check
(lambda _
;; Some of the 'integration' tests require network access or
;; login credentials.
- (invoke "nosetests" "--exclude=integration")
- #t)))))
+ (invoke "nosetests" "--exclude=integration"))))))
(native-inputs
`(("python-docutils" ,python-docutils)
("python-mock" ,python-mock)