summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-04 17:14:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-04 17:14:33 +0100
commit7bd99943843da0272ad62cf38cf1e5272e15546d (patch)
treedd949d4500f12f45381af4326a70bd6067ac3698 /gnu/packages/python-web.scm
parent10e1025c636ebcaf44954602c1b60f096c195490 (diff)
downloadguix-patches-7bd99943843da0272ad62cf38cf1e5272e15546d.tar
guix-patches-7bd99943843da0272ad62cf38cf1e5272e15546d.tar.gz
gnu: Add python-gwebsockets.
* gnu/packages/python-web.scm (python-gwebsockets): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 25136c8448..07a3582bd5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2019-2022 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017, 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
@@ -93,6 +93,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages django)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages groff)
@@ -3612,6 +3613,26 @@ library.")
@code{Requests} with @code{Gevent} to make asynchronous HTTP Requests easily")
(license license:bsd-2)))
+(define-public python-gwebsockets
+ (package
+ (name "python-gwebsockets")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gwebsockets" version))
+ (sha256
+ (base32
+ "0kgq7wssz0mrhxdafkfc9prj0qjv9z0lyivyqvjvjnnypg54di7m"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-pygobject))
+ (home-page "https://github.com/sugarlabs/gwebsockets")
+ (synopsis "GLib based websockets server")
+ (description "This package provides a websocket server written in Python.
+It uses GIO for network communication and hence it easily integrates with the
+GLib mainloop.")
+ (license license:asl2.0)))
+
(define-public python-dpkt
(package
(name "python-dpkt")