summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-17 18:10:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-17 18:13:19 +0300
commit7823c6504082a0cfbd98beb301e041fb8bc4e44e (patch)
tree5db03a05cf85484e5c820d82e9545a0c511e4f87 /gnu/packages/python-crypto.scm
parente80022ff3adde3184bed6758f604e3aa12942865 (diff)
downloadguix-patches-7823c6504082a0cfbd98beb301e041fb8bc4e44e.tar
guix-patches-7823c6504082a0cfbd98beb301e041fb8bc4e44e.tar.gz
gnu: python-pgpy: Update to 0.6.0.
* gnu/packages/python-crypto.scm (python-pgpy): Update to 0.6.0. [propagated-inputs]: Remove python-singledispatch and python-six.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 0dbbb15448..79c323663a 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1610,13 +1610,13 @@ signatures.")
(define-public python-pgpy
(package
(name "python-pgpy")
- (version "0.5.3")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "PGPy" version))
(sha256
- (base32 "11rrq15gmn6qbahli7czflfcngjl7zyybjlvk732my6axnf2d754"))))
+ (base32 "10w3h934fi1ijx72ppn67a50yhkf8n1db6xx02gk2fjc7wsjx717"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1628,8 +1628,7 @@ signatures.")
(native-inputs
(list python-pytest
python-wheel))
- (propagated-inputs (list python-cryptography python-pyasn1
- python-singledispatch python-six))
+ (propagated-inputs (list python-cryptography python-pyasn1))
(home-page "https://github.com/SecurityInnovation/PGPy")
(synopsis "Python implementation of OpenPGP")
(description