summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-11 18:21:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:37 +0300
commit1f04e3d02711e07035ca8dfb6e8778d8a03abbfe (patch)
tree96eb9a70c61e73dcc09893437196f8fd987e1496 /gnu/packages/python-crypto.scm
parenta91628366aee57020bb758cdee2229e58993f4d9 (diff)
downloadguix-patches-1f04e3d02711e07035ca8dfb6e8778d8a03abbfe.tar
guix-patches-1f04e3d02711e07035ca8dfb6e8778d8a03abbfe.tar.gz
gnu: python-cryptography-rust: Enable tests.
* gnu/packages/python-crypto.scm (python-cryptography-rust) [arguments]: Don't skip the tests. Add a custom 'check phase.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index bcef7c5db6..cfd1146f06 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -557,11 +557,6 @@ ciphers, message digests and key derivation functions.")
(guix build utils)
(srfi srfi-1)
(ice-9 match))
- ;; XXX: Building the test objects appear to fail due to a missing link
- ;; directive to Python's shared library (e.g.: "ld:
- ;; cryptography_rust.c950d742-cgu.11:(.text._ZN3...+0x57): undefined
- ;; reference to `PyLong_FromLong'").
- #:tests? #f
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'chdir
@@ -579,6 +574,11 @@ ciphers, message digests and key derivation functions.")
(apply (assoc-ref %standard-phases 'configure)
(append args
(list #:inputs (alist-delete "source" inputs))))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; As seen in tox.ini
+ (invoke "cargo" "test" "--no-default-features"))))
(add-after 'install 'install-shared-library
(lambda _
(install-file "target/release/libcryptography_rust.so"