summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-18 16:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-18 19:50:01 +0200
commit0e47fcced442d8e7c1b05184fdc1c14f10ed04ec (patch)
tree4ae844bc0ec3c670f8697bdc24362c122fa718ad /gnu/packages/python-crypto.scm
parente4b70bc55a538569465bcedee19d1f2607308e65 (diff)
parent8b1bde7bb3936a64244824500ffe60f123704437 (diff)
downloadguix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar
guix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm95
1 files changed, 26 insertions, 69 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 3a201e4095..d3add550fe 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -469,6 +469,32 @@ general production use. Include this module and use its backends at your own
risk.")
(license license:expat)))
+(define-public python-certauth
+ (package
+ (name "python-certauth")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "certauth" version))
+ (sha256
+ (base32
+ "1yxqfb5131wahjyw9pxz03bq476rcfx62s6k53xx4cqbzzgdaqkq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyopenssl" ,python-pyopenssl)
+ ("python-tldextract" ,python-tldextract)))
+ (native-inputs
+ `(("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://github.com/ikreymer/certauth")
+ (synopsis "Certificate authority creation tool")
+ (description "This package provides a small library, built on top of
+pyOpenSSL, which allows for creating a custom certificate authority (CA)
+certificate, and generating on-demand dynamic host certs using that CA
+certificate. It is most useful for use with a man-in-the-middle HTTPS proxy,
+for example, for recording or replaying web content.")
+ (license license:expat)))
+
(define-public python-certifi
(package
(name "python-certifi")
@@ -816,75 +842,6 @@ of improving usability, security and speed.")
(define-public python2-pynacl
(package-with-python2 python-pynacl))
-(define-public python2-pgpdump
- (package
- (name "python2-pgpdump")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pgpdump" version))
- (sha256
- (base32
- "0s4nh8h7qsdj2yf29bspjs1zvxd4lcd11r6g11dp7fppgf2h0iqw"))))
- (build-system python-build-system)
-
- ;; Currently fails to build with Python 3.
- (arguments `(#:python ,python-2))
-
- (home-page "https://github.com/toofishes/python-pgpdump")
- (synopsis "Python library for parsing PGP packets")
- (description
- "Python-pgpdump is an OpenPGP packet parser based on
-@uref{http://www.mew.org/~kazu/proj/pgpdump/, pgpdump}. It notably supports:
-
-@itemize
-@item signature packets;
-@item public key packets;
-@item secret key packets;
-@item trust, user ID, and user attribute packets;
-@item ASCII-armor decoding and CRC check.
-@end itemize\n")
- (license license:bsd-3)))
-
-(define-public python2-roca-detect
- (package
- (name "python2-roca-detect")
- (version "1.0.8")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "roca-detect" version))
- (sha256
- (base32
- "1di4akyw2lf5r8zfwvyhkilz8jv8g4b66rgaqwfabmjwma6gnw27"))))
- (build-system python-build-system)
- (native-inputs
- ;; TODO: apk_parse_ph4, pyjks
- `(("python2-dateutil" ,python2-dateutil)
- ("python2-six" ,python2-six)
- ("python2-cryptography" ,python2-cryptography)
- ("python2-future" ,python2-future)
- ("python2-coloredlogs" ,python2-coloredlogs)
- ("python2-pgpdump" ,python2-pgpdump)))
- (arguments
- `(;; Basic testing routine is quite simple and works with Py3
- ;; but the rest of the code that processes the different
- ;; key formats and extracts the modulus for inspection is
- ;; not yet fully py3 ready.
- #:python ,python-2))
- (home-page "https://github.com/crocs-muni/roca")
- (synopsis "ROCA detection tool")
- (description
- "This tool is related to the paper entitled @i{Return of the
-Coppersmith’s Attack: Practical Factorization of Widely Used RSA Moduli}. It
-enables you to test public RSA keys for a presence of the described
-vulnerability. Currently the tool supports the following key formats: X.509
-Certificate (DER encoded, PEM encoded), RSA PEM (encoded private key, public
-key), SSH public key, ASC-encoded OpenPGP key, APK Android application, LDIFF
-file, and more.")
- (license license:gpl3)))
-
(define-public python-blurhash
(package
(name "python-blurhash")