summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:28:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit2aab587f842908a886e3bd08b028885dddd650e0 (patch)
tree87c0723a9ae2c69ab6920d90b6e87ad8510492fe /gnu/packages/python-crypto.scm
parent5664bcdcb0e4c10dfe48dd5e4730fc3c746a21e2 (diff)
parent65c46e79e0495fe4d32f6f2725d7233fff10fd70 (diff)
downloadguix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar
guix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 0a1ace6328..900b6ddfe6 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -335,7 +335,7 @@ etc.). The package is structured to make adding new modules easy.")
(define-public python2-pycrypto
(let ((pycrypto (package-with-python2 python-pycrypto)))
- (package (inherit pycrypto)
+ (package/inherit pycrypto
(inputs
`(("python" ,python-2)
,@(alist-delete
@@ -554,7 +554,7 @@ message digests and key derivation functions.")
(define-public python2-cryptography
(let ((crypto (package-with-python2
(strip-python2-variant python-cryptography))))
- (package (inherit crypto)
+ (package/inherit crypto
(propagated-inputs
`(("python2-ipaddress" ,python2-ipaddress)
("python2-backport-ssl-match-hostname"
@@ -1091,6 +1091,10 @@ provides drop-in compatibility with PyCrypto.")))
(sha256
(base32 "09yirf3w77w6f49q6nxhrjm9c3a4y9s30s1k09chqrw8zdgx8sjc"))))
(build-system python-build-system)
+ (arguments
+ `(;; FIXME: Tests start failing with time due to date checks in TLS
+ ;; certificates.
+ #:tests? #f))
(inputs `(("openssl" ,openssl)))
(native-inputs `(("swig" ,swig)))
(home-page "https://gitlab.com/m2crypto/m2crypto")
@@ -1108,7 +1112,7 @@ through the Engine interface.")
(define-public python2-m2crypto
(let ((m2crypto (package-with-python2
(strip-python2-variant python-m2crypto))))
- (package (inherit m2crypto)
+ (package/inherit m2crypto
(propagated-inputs
`(("python2-typing" ,python2-typing))))))