summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-06-15 19:09:45 +0200
committerjgart <jgart@dismail.de>2024-06-26 01:37:27 -0500
commit89fb7c2784a3fbbf78863660c92e87b2d11c0016 (patch)
tree763aeef5991c368506c3f2bb1ac1e306a216ac21 /gnu/packages/python-check.scm
parent20f3f4f3f08e8693f33de1cb83f20246d6c8d4f1 (diff)
downloadguix-patches-89fb7c2784a3fbbf78863660c92e87b2d11c0016.tar
guix-patches-89fb7c2784a3fbbf78863660c92e87b2d11c0016.tar.gz
gnu: Add python-pytest-subprocess.
* gnu/packages/python-check.scm (python-pytest-subprocess): New variable. Change-Id: Id651d945836879e71eb30f51bc392f3027bcad6e Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1890042420..fb83031094 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2310,6 +2310,35 @@ execution of a test suite. It will also store a history of all test runs to
help in debugging failures and optimizing the scheduler to improve speed.")
(license license:asl2.0)))
+(define-public python-pytest-subprocess
+ (package
+ (name "python-pytest-subprocess")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch) ;no tests in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/aklajnert/pytest-subprocess")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "103nxv37sjvxlwmw87hxsrphkxkryv4dgb65kjjfr4722r37vmxv"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-anyio
+ python-coverage
+ python-docutils
+ python-nox
+ python-pygments
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-rerunfailures))
+ (home-page "https://github.com/aklajnert/pytest-subprocess")
+ (synopsis "Fake subprocess for Pytest")
+ (description
+ "This package provides a plugin to fake subprocess for Pytest.")
+ (license license:expat)))
+
;; This is only used by python-sanic
(define-public python-pytest-sanic
(package