summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-29 10:48:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:15 +0200
commit859953f60a8a9c9f3e2d6fed13e26f90ea20f016 (patch)
treed6b49d91b21a8fd03f6673b6744f7627eac7fbf8 /gnu/packages/python-check.scm
parent5f186e2f7931ce1f777fc0417b707f7469944425 (diff)
downloadguix-patches-859953f60a8a9c9f3e2d6fed13e26f90ea20f016.tar
guix-patches-859953f60a8a9c9f3e2d6fed13e26f90ea20f016.tar.gz
gnu: Add python-nbmake.
* gnu/packages/python-check.scm (python-nbmake): New variable. Change-Id: If062d0e34329e99b5bb87588e7ddf149c65bfdfb
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 6fdfaad6fb..9124e9c1c4 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages django)
#:use-module (gnu packages docker)
+ #:use-module (gnu packages jupyter)
#:use-module (gnu packages openstack)
#:use-module (gnu packages perl)
#:use-module (gnu packages python-build)
@@ -1515,6 +1516,39 @@ new fixtures, new methods and new comparison objects.")
(description "This package provides a pytest plugin for aiohttp support.")
(license license:asl2.0)))
+(define-public python-nbmake
+ (package
+ (name "python-nbmake")
+ (version "1.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/treebeardtech/nbmake")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06syl819kwqhmjwp34lri31f0pypwnxs9j03s5lbk12w42mihzdi"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-ipykernel python-nbclient python-nbformat python-pygments))
+ (native-inputs
+ (list python-poetry-core
+ python-pytest
+ python-pytest-xdist
+ python-pyyaml))
+ (home-page "https://github.com/treebeardtech/nbmake")
+ (synopsis "Pytest plugin for testing notebooks")
+ (description "This package provides a Pytest plugin for testing Jupyter
+notebooks.")
+ (license license:asl2.0)))
+
(define-public python-nbval
(package
(name "python-nbval")