summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:47:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:47:09 +0300
commit0449f4ebabe54085d75614088e9a9170e464bd9f (patch)
tree5c3b8f49f0964af9ff065335c2bb1daaae974ee2 /gnu/packages/python-check.scm
parent5c4332e5100f3cb008a542a6327b704e42100b3c (diff)
downloadguix-patches-0449f4ebabe54085d75614088e9a9170e464bd9f.tar
guix-patches-0449f4ebabe54085d75614088e9a9170e464bd9f.tar.gz
gnu: Add python-pytest-services.
* gnu/packages/python-check.scm (python-pytest-services): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 52f53f58cc..e3f0f6acbe 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -387,6 +387,31 @@ for the @code{pytest} framework.")
rounds that are calibrated to the chosen timer.")
(license license:bsd-2)))
+(define-public python-pytest-services
+ (package
+ (name "python-pytest-services")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-services" version))
+ (sha256
+ (base32
+ "0b2zfv04w6m3gp2v44ifdhx22vcji069qnn95ry3zcyxib7cjnq3"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; Tests not included in release tarball.
+ (propagated-inputs
+ `(("python-psutil" ,python-psutil)
+ ("python-requests" ,python-requests)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/pytest-dev/pytest-services")
+ (synopsis "Services plugin for pytest testing framework")
+ (description
+ "This plugin provides a set of fixtures and utility functions to start
+service processes for your tests with pytest.")
+ (license license:expat)))
+
(define-public python-pytest-flask
(package
(name "python-pytest-flask")