summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-29 12:43:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-02 21:47:28 -0400
commitf7f5caf7ea78d2c257a081c8fcf212e507fe2ab6 (patch)
tree3e62acad2e2cfd9be6f0d1a3281f97181e5d325f /gnu/packages/python-check.scm
parent01f3f0e928bd614b8b2c9aea5b93bdc6a4b07963 (diff)
downloadguix-patches-f7f5caf7ea78d2c257a081c8fcf212e507fe2ab6.tar
guix-patches-f7f5caf7ea78d2c257a081c8fcf212e507fe2ab6.tar.gz
gnu: Add python-pyux.
* gnu/packages/python-check.scm (python-pyux): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 4873df4b48..498f495584 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
@@ -852,6 +852,26 @@ also ensuring that the notebooks are running without errors.")
variables in the @file{pytest.ini} file.")
(license license:expat)))
+(define-public python-pyux
+ (package
+ (name "python-pyux")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyux" version))
+ (sha256
+ (base32
+ "1i17xh4dy238ibrjdgh8vn78fk5q6dj37mcznpvdfzidj57js7ca"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;the mini test suite fails
+ (home-page "https://github.com/farizrahman4u/pyux")
+ (synopsis "Utility to check API integrity in Python libraries")
+ (description "The pyux utility allows to detect API changes in Python
+libraries.")
+ (license license:expat)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")