summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-18 15:42:13 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-19 21:56:58 -0500
commit30429bc20fb4f211567933cff3319ebb0ed906c3 (patch)
tree773b2d1a2ecf819ce386c552e2f92ca905b612e0 /gnu/packages/python-check.scm
parent762238c4d3210b5102dbe0b03238f74d580e1c68 (diff)
downloadguix-patches-30429bc20fb4f211567933cff3319ebb0ed906c3.tar
guix-patches-30429bc20fb4f211567933cff3319ebb0ed906c3.tar.gz
gnu: Add python-stestr.
* gnu/packages/python-check.scm (python-stestr): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index dcd4bb90d8..cad9a0c94a 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -28,6 +28,7 @@
(define-module (gnu packages python-check)
#:use-module (gnu packages)
#:use-module (gnu packages check)
+ #:use-module (gnu packages openstack)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages web)
@@ -1078,3 +1079,36 @@ any Python VM with basically no runtime overhead.")
(description "Robber is a Python assertion library for test-driven and
behavior-driven development (TDD and BDD).")
(license license:expat)))
+
+(define-public python-stestr
+ (package
+ (name "python-stestr")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "stestr" version))
+ (sha256
+ (base32
+ "0adhqp9c9338wlvlq776k57k04lyxp38bv591afdm9gjsn2qn1zm"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;to avoid circular dependencies
+ (native-inputs
+ `(("python-pbr" ,python-pbr)))
+ (propagated-inputs
+ `(("python-cliff" ,python-cliff)
+ ("python-fixtures" ,python-fixtures)
+ ("python-future" ,python-future)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-subunit" ,python-subunit)
+ ("python-testtools" ,python-testtools)
+ ("python-voluptuous" ,python-voluptuous)))
+ (home-page "https://stestr.readthedocs.io/en/latest/")
+ (synopsis "Parallel Python test runner")
+ (description "This package provides the @command{stestr} command, a
+parallel Python test runner built around @code{subunit}. It is designed to
+execute @code{unittest} test suites using multiple processes to split up
+execution of a test suite. It will also store a history of all test runs to
+help in debugging failures and optimizing the scheduler to improve speed.")
+ (license license:asl2.0)))