summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 14:17:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 14:18:35 +0300
commitc94d42d95134fc38e0b02f1c6c99e7703cf85683 (patch)
tree06879f3958f476eb54dbb68df885d7fe126ffb94 /gnu/packages/python-check.scm
parentb8295d2529f3330e5fd09550403a55355a392fa7 (diff)
downloadguix-patches-c94d42d95134fc38e0b02f1c6c99e7703cf85683.tar
guix-patches-c94d42d95134fc38e0b02f1c6c99e7703cf85683.tar.gz
gnu: python-pytest-isort: Honor #:tests in check phase.
* gnu/packages/python-check.scm (python-pytest-isort)[arguments]: Honor #:tests flag.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5436a878c6..740b9438ac 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -739,8 +739,9 @@ compliance.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
(propagated-inputs
`(("python-isort" ,python-isort)
("python-pytest" ,python-pytest)))