summaryrefslogtreecommitdiff
path: root/gnu/packages/purescript.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-13 23:39:52 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-13 23:45:53 -0500
commit01f0707207741ce2a5d7509a175464799b08aea6 (patch)
tree08e8f4da56f26363c3b53e0442a21b286b55e0e5 /gnu/packages/purescript.scm
parent734bcf13139119daf8685f93b056c3422dbfa264 (diff)
parent6985a1acb3e9cc4cad8b6f63d77154842d25c929 (diff)
downloadguix-patches-01f0707207741ce2a5d7509a175464799b08aea6.tar
guix-patches-01f0707207741ce2a5d7509a175464799b08aea6.tar.gz
Merge branch 'staging' into 'core-updates'.
Conflicts: gnu/local.mk gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/guile.scm gnu/packages/node.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/python-xyz.scm gnu/packages/python.scm gnu/packages/tls.scm gnu/packages/vpn.scm gnu/packages/xorg.scm
Diffstat (limited to 'gnu/packages/purescript.scm')
-rw-r--r--gnu/packages/purescript.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/purescript.scm b/gnu/packages/purescript.scm
index 13cd773839..cc51b163c9 100644
--- a/gnu/packages/purescript.scm
+++ b/gnu/packages/purescript.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +48,7 @@
(define-public purescript
(package
(name "purescript")
- (version "0.13.6")
+ (version "0.13.8")
(source
(origin
(method url-fetch)
@@ -57,7 +58,7 @@
".tar.gz"))
(sha256
(base32
- "1xss3wpv6wb38gsh9r635s09cxzmiz81hhssdxzdba2pw6ifzx8j"))
+ "0sh9z3ir3jiwmi5h95v9p7j746xxidg1hrxha89c0zl6vr4sq7vh"))
(patches (search-patches "purescript-relax-dependencies.patch"))))
(build-system haskell-build-system)
(inputs
@@ -70,6 +71,7 @@
("ghc-blaze-html" ,ghc-blaze-html)
("ghc-bower-json" ,ghc-bower-json)
("ghc-boxes" ,ghc-boxes)
+ ("ghc-cborg" ,ghc-cborg)
("ghc-cheapskate" ,ghc-cheapskate)
("ghc-clock" ,ghc-clock)
("ghc-cryptonite" ,ghc-cryptonite)
@@ -95,6 +97,7 @@
("ghc-scientific" ,ghc-scientific)
("ghc-semialign" ,ghc-semialign)
("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-serialise" ,ghc-serialise)
("ghc-sourcemap" ,ghc-sourcemap)
("ghc-split" ,ghc-split)
("ghc-stringsearch" ,ghc-stringsearch)