summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-08-07 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-14 02:00:01 +0200
commit2790d118b2f68e9d3599ccbe5712ddbd1dde3fa4 (patch)
treea88de29e07fbc59ee025dab82293a77a94c13d6a /gnu/packages/pulseaudio.scm
parent8e82a70a4f28e1c7df6f1342c54cfff60e69e962 (diff)
downloadguix-patches-2790d118b2f68e9d3599ccbe5712ddbd1dde3fa4.tar
guix-patches-2790d118b2f68e9d3599ccbe5712ddbd1dde3fa4.tar.gz
gnu: noise-suppression-for-voice: Rename from ‘rnnoise’.
This is a set of plug-ins *based on* Xiph's rnnoise package (also in Guix). * gnu/packages/pulseaudio.scm (rnnoise): Rename this variable… (noise-suppression-for-voice): …to this. [noisetorch](inputs): Adjust its only user.
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 1f2dea5a8c..96ba13d484 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -450,9 +450,9 @@ only configure local servers, and requires that a special module
module-gsettings is loaded in the sound server.")
(license l:gpl2)))
-(define-public rnnoise
+(define-public noise-suppression-for-voice
(package
- (name "rnnoise")
+ (name "noise-suppression-for-voice")
(version "0.91")
(source
(origin
@@ -472,14 +472,15 @@ module-gsettings is loaded in the sound server.")
pulseaudio))
(home-page "https://github.com/werman/noise-suppression-for-voice")
(synopsis "Real-time Noise suppression plugin based on Xiph's RNNoise")
- (description "The plugin is meant to suppress a wide range of noise
-origins: computer fans, office, crowd, airplane, car, train, construction.
+ (description "This plug-in is meant to suppress a wide range of noise
+origins: computer fans, offices, crowds, airplanes, cars, trains,
+construction, and more.
Mild background noise is always suppressed, loud sounds, like
clicking of mechanical keyboard, are suppressed while there is no voice
however they are only reduced in volume when voice is present.
-The plugin is made to work with 1 or 2 channels (ladspa plugin),
+The plug-in is made to work with 1 or 2 channels (LADSPA plugin),
16 bit, 48000 Hz audio input.")
(license l:gpl3)))
@@ -521,7 +522,7 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
(with-directory-excursion "src/github.com/noisetorch/NoiseTorch"
(invoke "go" "generate")))))))
(inputs
- (list rnnoise))
+ (list noise-suppression-for-voice))
(home-page "https://github.com/noisetorch/NoiseTorch")
(synopsis "Real-time microphone noise suppression")
(description "NoiseTorch creates a virtual PulseAudio microphone that