summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-06-11 23:52:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-06-11 23:52:15 +0200
commita032b4454b3fc67e11e9fc2d8c2345288065fa29 (patch)
treec208124b79dbd2224b68c52106aa72ff2ebfa7ab /gnu/packages/pulseaudio.scm
parentb5724230fed2d043206df20d12a45bb962b7ee77 (diff)
parent6321ce42ab4d9ab788d858cb19bde4aa7a0e3ecc (diff)
downloadguix-patches-a032b4454b3fc67e11e9fc2d8c2345288065fa29.tar
guix-patches-a032b4454b3fc67e11e9fc2d8c2345288065fa29.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm23
1 files changed, 19 insertions, 4 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 43816e09f8..bac92eafa9 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -135,10 +135,13 @@ rates.")
(snippet
;; Disable console-kit support by default since it's deprecated
;; anyway.
- '(substitute* "src/daemon/default.pa.in"
- (("load-module module-console-kit" all)
- (string-append "#" all "\n"))))
+ '(begin
+ (substitute* "src/daemon/default.pa.in"
+ (("load-module module-console-kit" all)
+ (string-append "#" all "\n")))
+ #t))
(patches (search-patches
+ "pulseaudio-glibc-2.27.patch"
"pulseaudio-fix-mult-test.patch"
"pulseaudio-longer-test-timeout.patch"))))
(build-system gnu-build-system)
@@ -150,6 +153,13 @@ rates.")
(assoc-ref %outputs "out")
"/lib/udev/rules.d"))
#:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ ;; TODO: Remove this custom bootstrap phase when
+ ;; pulseaudio-glibc-2.27.patch is removed.
+ (lambda _
+ (patch-shebang "git-version-gen")
+ (setenv "NOCONFIGURE" "1")
+ (invoke "bash" "bootstrap.sh")))
(add-before 'check 'pre-check
(lambda _
;; 'tests/lock-autospawn-test.c' wants to create a file
@@ -177,7 +187,12 @@ rates.")
("eudev" ,eudev) ;for the detection of hardware audio devices
("check" ,check)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ;; TODO: Remove "autoconf", "automake", and "libtool" from
+ ;; native-inputs when pulseaudio-glibc-2.27.patch is removed.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(propagated-inputs
;; 'libpulse*.la' contain `-lgdbm' and `-lcap', so propagate them.
`(("libcap" ,libcap)