summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 09:50:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 10:06:36 +0200
commit5f8491ea95d7ba88801aa28b6d2b98f30b033186 (patch)
treea112a5ec1e71ea535a37b2329ef2a031f6b34a3d /gnu/packages/protobuf.scm
parent04ed3821cc7b15a22946ca972525626b41d71763 (diff)
downloadguix-patches-5f8491ea95d7ba88801aa28b6d2b98f30b033186.tar
guix-patches-5f8491ea95d7ba88801aa28b6d2b98f30b033186.tar.gz
gnu: python-protobuf: Update to 3.20.1.
* gnu/packages/protobuf.scm (python-protobuf): Update to 3.20.1. [native-inputs]: Remove python-wheel. [propagated-inputs]: Remove python-six.
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 3a74a4c613..8991fc8c57 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -233,19 +233,15 @@ encoder in C++. The developer using protozero has to manually translate the
(define-public python-protobuf
(package
(name "python-protobuf")
- (version "3.12.4")
+ (version "3.20.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "protobuf" version))
(sha256
(base32
- "0mj6z58aiw532s1mq48m9xdrm3gdyp2vv9cdinfb5wmnfpm5m7n9"))))
+ "1ja2vpk9nklllmsirmil2s4l7ni9yfqvbvj47zz5xx17s1k1bhxd"))))
(build-system python-build-system)
- (native-inputs
- (list python-wheel))
- (propagated-inputs
- (list python-six))
(home-page "https://github.com/google/protobuf")
(synopsis "Protocol buffers is a data interchange format")
(description