summaryrefslogtreecommitdiff
path: root/gnu/packages/popt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 12:51:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 13:11:40 -0400
commit5e2140511c1ad9ccd731438b74d61b62111da1e6 (patch)
treea4ff748ad26e121b88469b5d921001ef1382be8f /gnu/packages/popt.scm
parent9e3a5ee417ea7fe9721be8804ff047e80c4f22ed (diff)
parent353bdae32f72b720c7ddd706576ccc40e2b43f95 (diff)
downloadguix-patches-5e2140511c1ad9ccd731438b74d61b62111da1e6.tar
guix-patches-5e2140511c1ad9ccd731438b74d61b62111da1e6.tar.gz
Merge branch 'staging'
Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/gdb.scm gnu/packages/llvm.scm gnu/packages/package-management.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/popt.scm')
-rw-r--r--gnu/packages/popt.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index df80f12077..11d2b1827d 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -59,27 +59,23 @@ line syntax.")
(define-public popt
(package
(name "popt")
- (version "1.16")
+ (version "1.18")
(source (origin
(method url-fetch)
- ;; The original rpm5.org domain is not accessible since
- ;; 2019-06-13, so use Debians copy of the tarball.
- (uri (string-append "https://deb.debian.org/debian/pool/main"
- "/p/popt/popt_" version ".orig.tar.gz"))
- ;; Ensure the file name stays the same to prevent rebuilds.
- (file-name (string-append "popt-" version ".tar.gz"))
+ (uri (string-append "http://ftp.rpm.org/popt/releases"
+ "/popt-1.x/popt-" version ".tar.gz"))
(sha256
(base32
- "1j2c61nn2n351nhj4d25mnf3vpiddcykq005w2h6kw79dwlysa77"))))
+ "1lf5zlj5rbg6s4bww7hbhpca97prgprnarx978vcwa0bl81vqnai"))))
(build-system gnu-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-test
(lambda _
- (substitute* "test-poptrc.in"
+ (substitute* "tests/test-poptrc.in"
(("/bin/echo") (which "echo")))
- (substitute* "testit.sh" ; don't expect old libtool names
+ (substitute* "tests/testit.sh" ;don't expect old libtool names
(("lt-test1") "test1"))
#t)))))
(home-page "http://rpm5.org/files/popt/")