summaryrefslogtreecommitdiff
path: root/gnu/packages/popt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-20 23:38:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-20 23:38:56 +0200
commit6cb1ef9ea28ee14b3bb5442e8af1f54c27802f09 (patch)
treec2c35f733d250f86eb052d174fcb1c24a54fea79 /gnu/packages/popt.scm
parent20e4ee1e3b7044d9f64de02c6237b00e5a57da35 (diff)
parent010689e7067df1288af29176f4a8639de816b1ef (diff)
downloadguix-patches-6cb1ef9ea28ee14b3bb5442e8af1f54c27802f09.tar
guix-patches-6cb1ef9ea28ee14b3bb5442e8af1f54c27802f09.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/popt.scm')
-rw-r--r--gnu/packages/popt.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index e3f5fa1895..7f6a2e8e6a 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2016, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -24,7 +24,8 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
- #:use-module (guix licenses))
+ #:use-module (guix licenses)
+ #:use-module (gnu packages texinfo))
(define-public argtable
(package
@@ -126,19 +127,21 @@ appropriately.")
(define-public gengetopt
(package
(name "gengetopt")
- (version "2.22.6")
+ (version "2.23")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/gengetopt/gengetopt-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256
(base32
- "1xq1kcfs6hri101ss4dhym0jn96z4v6jdvx288mfywadc245mc1h"))))
+ "1b44fn0apsgawyqa4alx2qj5hls334mhbszxsy6rfr0q074swhdr"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; not supported
#:parallel-tests? #f)) ; likewise
+ (native-inputs
+ `(("texinfo" ,texinfo)))
(synopsis "Create parsers for command line options")
(description
"GNU Gengetopt is a program to generate a C/C++ function for parsing