summaryrefslogtreecommitdiff
path: root/gnu/packages/popt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 00:09:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-15 00:09:46 +0100
commit3cfe76bec06fbd8bb7e7cb3387866fefbcad674f (patch)
treeb66780d205fb50fd44d0bbb38f5df99cf3167ba1 /gnu/packages/popt.scm
parentec836b46bf52a5f86c61f50e3a2c3330a7ee3665 (diff)
parent574a71a7a9668aa184661c58e1f18a4d4fccd792 (diff)
downloadguix-patches-3cfe76bec06fbd8bb7e7cb3387866fefbcad674f.tar
guix-patches-3cfe76bec06fbd8bb7e7cb3387866fefbcad674f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/popt.scm')
-rw-r--r--gnu/packages/popt.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index 7f6a2e8e6a..6346c54f22 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -62,8 +62,13 @@ line syntax.")
(version "1.16")
(source (origin
(method url-fetch)
- (uri (string-append "http://rpm5.org/files/popt/popt-"
- version ".tar.gz"))
+ ;; The rpm5.org domain does not resolve since 2019-06-13, so we
+ ;; borrow Debians infrastructure for the source download.
+ (uri (list (string-append "https://deb.debian.org/debian/pool/main"
+ "/p/popt/popt_" version ".orig.tar.gz")
+ ;; Keep the old URL around in case it reappears.
+ (string-append "http://rpm5.org/files/popt/popt-"
+ version ".tar.gz")))
(sha256
(base32
"1j2c61nn2n351nhj4d25mnf3vpiddcykq005w2h6kw79dwlysa77"))))