summaryrefslogtreecommitdiff
path: root/gnu/packages/plotutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-22 18:14:04 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-22 18:14:04 +0200
commit233df51ebc162bf95dfadf914914cbfbc6984651 (patch)
tree06fa8d78bbe97619450a88d8a38d01dc3775655b /gnu/packages/plotutils.scm
parent43cec3fb1ea54dedee8a5f613c833958c76892f4 (diff)
parent180a8986e57a6cfb65a8cddabcb430f23801832b (diff)
downloadguix-patches-233df51ebc162bf95dfadf914914cbfbc6984651.tar
guix-patches-233df51ebc162bf95dfadf914914cbfbc6984651.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/plotutils.scm')
-rw-r--r--gnu/packages/plotutils.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index ab0ca08528..0e65cb319f 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -194,7 +194,15 @@ colors, styles, options and details.")
(native-inputs
`(("gs" ,ghostscript) ;For tests
("texinfo" ,texinfo) ;For generating documentation
- ("texlive" ,texlive) ;For tests and documentation
+ ;; For the manual and the tests.
+ ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
+ texlive-generic-ifxetex
+ texlive-latex-amsfonts
+ texlive-latex-geometry
+ texlive-latex-graphics
+ texlive-latex-oberdiek
+ texlive-latex-parskip
+ texlive-tex-texinfo)))
("emacs" ,emacs-minimal)
("perl" ,perl)))
(inputs
@@ -234,6 +242,12 @@ colors, styles, options and details.")
;; "failed to create directory /homeless-shelter/.asy" error.
(lambda _
(setenv "HOME" "/tmp")
+ ;; The "gs" test fails, complaining about an incompatible
+ ;; Ghostscript version. Not sure what's going on... Is this
+ ;; because I've just replaced texlive with texlive-union?
+ (substitute* "tests/Makefile"
+ (("^(TESTDIRS =.*) gs(.*)" begin end)
+ (string-append begin " " end)))
#t))
(add-after 'install 'install-Emacs-data
(lambda* (#:key outputs #:allow-other-keys)