summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-10-30 21:56:51 +0000
committerLudovic Courtès <ludo@gnu.org>2022-11-14 12:31:34 +0100
commitcf8e5f4ff8f1757e3e9d71f1b0a63406d835a0df (patch)
treecbccf0c0718907b9115ba1a481701d1b20d0f248 /gnu/packages/photo.scm
parent98e4bfe96f2c99daa0b66b65c1d379bb385301a8 (diff)
downloadguix-patches-cf8e5f4ff8f1757e3e9d71f1b0a63406d835a0df.tar
guix-patches-cf8e5f4ff8f1757e3e9d71f1b0a63406d835a0df.tar.gz
gnu: Add librtprocess.
* gnu/packages/photo.scm (librtprocess): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 642694bda1..d86d4e7294 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020. 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -807,3 +808,26 @@ workflow by facilitating the handling of large numbers of images. Most raw
formats are supported, including Pentax Pixel Shift, Canon Dual-Pixel, and those
from Foveon and X-Trans sensors.")
(license license:gpl3+)))
+
+(define-public librtprocess
+ (package
+ (name "librtprocess")
+ (version "0.12.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CarVac/librtprocess")
+ (commit version)))
+ (sha256
+ (base32
+ "0v0zwbdbc1fn7iy6wi0m6zgb86qdx1ijnv548d0ydbr8cm4klnpz"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; No tests
+ (list #:tests? #f))
+ (home-page "https://github.com/CarVac/librtprocess")
+ (synopsis "Highly optimized library for processing RAW images")
+ (description
+ "This package provides RawTherapee's highly optimized RAW processing routines.")
+ (license license:gpl3+)))