summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-18 02:07:10 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-01 02:00:17 +0200
commit51b716f7f2cf519273371c294ab03d310a246369 (patch)
tree3b23701d52c4039d27a96c184895e8bbea3b3fd2 /gnu/packages/photo.scm
parentdb5c49fc62aac63f52196a4566426d716768616d (diff)
downloadguix-patches-51b716f7f2cf519273371c294ab03d310a246369.tar
guix-patches-51b716f7f2cf519273371c294ab03d310a246369.tar.gz
gnu: enblend-enfuse: Fix build.
* gnu/packages/photo.scm (enblend-enfuse)[arguments]: Rewrite as a keyword/gexp list. Add a new 'add-missing-include phase to build with a recent GCC.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index da67d2352e..a7286fcf9a 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -32,6 +32,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -404,7 +405,16 @@ overlapping images, as well as some command line tools.")
vigra
zlib))
(arguments
- `(#:configure-flags `("--enable-openmp")))
+ (list #:configure-flags
+ #~(list "--enable-openmp")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'add-missing-include
+ (lambda _
+ (substitute* "src/minimizer.h"
+ ;; Fix error: ‘numeric_limits’ is not a member of ‘std’.
+ (("#include <vector>" line)
+ (string-append line "\n#include <limits>"))))))))
(home-page "http://enblend.sourceforge.net/")
(synopsis "Tools for combining and blending images")
(description