summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 06:40:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 21:41:51 +0100
commitb55cd95260988f365958ed5e4b1482be69197bb8 (patch)
tree4faef6a66d2414f65b54a7b904bf49ef52fe46d5 /gnu/packages/photo.scm
parent8175ed6fd30cb916a81a3236d47fb71b69ece815 (diff)
downloadguix-patches-b55cd95260988f365958ed5e4b1482be69197bb8.tar
guix-patches-b55cd95260988f365958ed5e4b1482be69197bb8.tar.gz
gnu: gphoto2: Update to 2.5.28.
* gnu/packages/photo.scm (gphoto2): Update to 2.5.28. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 785f795e99..913e1070f7 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -267,14 +267,14 @@ from digital cameras.")
(define-public gphoto2
(package
(name "gphoto2")
- (version "2.5.27")
+ (version "2.5.28")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gphoto/gphoto/" version
"/gphoto2-" version ".tar.bz2"))
(sha256
(base32
- "0f4d3q381jnnkcqkb2dj1k709skp65qihl5xm80zandvl69lw19h"))))
+ "0xbki37q9ja34igidr2vj0ps1lp7sfz4xpsmh8h9x89dy76qsr1a"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
@@ -287,13 +287,10 @@ from digital cameras.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* (find-files "tests/data" "\\.param$")
(("/usr/bin/env")
- (which "env")))
- #t)))
-
+ (which "env"))))))
;; FIXME: There is 1 test failure, most likely related to the build
;; environment.
#:tests? #f))
-
(home-page "http://www.gphoto.org/")
(synopsis "Command-line tools to access digital cameras")
(description