summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 14:43:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:50 +0200
commit3aeca58073eff8b7a835f6492e735dd152d9dc99 (patch)
tree25b66bc9201ceac81866d8423a2c64073a877bc2 /gnu/packages/perl.scm
parentaea0d94bc1f2c424d66f1a0f89f8d91642192c7d (diff)
downloadguix-patches-3aeca58073eff8b7a835f6492e735dd152d9dc99.tar
guix-patches-3aeca58073eff8b7a835f6492e735dd152d9dc99.tar.gz
gnu: biber -> texlive-biber.
Build from sources provided by TeX Live distribution, so they always match BibLaTeX version. * gnu/packages/patches/biber-adapt-perl-5.36.patch: Delete file. * gnu/local.mk: Apply removal. * gnu/packages/tex.scm (texlive-biber): New variable. (biber): Deprecate variable. (perl-text-bibtex): Move from here... * gnu/packages/perl.scm (perl-text-bibtex): ... to here.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 13bf3fa84c..57852a3cee 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -10631,6 +10631,46 @@ used to justify strings to various alignment styles.")
text sequences from strings.")
(license (package-license perl))))
+(define-public perl-text-bibtex
+ (package
+ (name "perl-text-bibtex")
+ (version "0.88")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AM/AMBS/Text-BibTeX-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0b7lmjvfmypps1nw6nsdikgaakm0n0g4186glaqazg5xd1p5h55h"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'add-output-directory-to-rpath
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "inc/MyBuilder.pm"
+ (("-Lbtparse" line)
+ (string-append "-Wl,-rpath="
+ (assoc-ref outputs "out") "/lib " line)))
+ #t))
+ (add-after 'unpack 'install-libraries-to-/lib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Build.PL"
+ (("lib64") "lib"))
+ #t)))))
+ (native-inputs
+ (list perl-capture-tiny perl-config-autoconf perl-extutils-libbuilder
+ perl-module-build))
+ (home-page "https://metacpan.org/release/Text-BibTeX")
+ (synopsis "Interface to read and parse BibTeX files")
+ (description "@code{Text::BibTeX} is a Perl library for reading, parsing,
+and processing BibTeX files. @code{Text::BibTeX} gives you access to the data
+at many different levels: you may work with BibTeX entries as simple field to
+string mappings, or get at the original form of the data as a list of simple
+values (strings, macros, or numbers) pasted together.")
+ (license license:perl-license)))
+
(define-public perl-text-charwidth
(package
(name "perl-text-charwidth")