summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-24 23:01:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 23:30:24 +0200
commit658a4976fad375c83ff56f12cb07128663962616 (patch)
tree6d8b42a78f05f7ef1b91ae6a7583d77d775f60f0 /gnu/packages/perl.scm
parentb547ef1d09f0909a47e75f2091068a0a21b523c4 (diff)
downloadguix-patches-658a4976fad375c83ff56f12cb07128663962616.tar
guix-patches-658a4976fad375c83ff56f12cb07128663962616.tar.gz
gnu: Add perl-moox-cmd.
* gnu/packages/perl.scm (perl-moox-cmd): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fe3c98aa9c..b9123513ef 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5485,6 +5485,38 @@ constraint with coercion to load the class.")
(description "Contains the MooX and MooX::Role packages.")
(license perl-license)))
+(define-public perl-moox-cmd
+ (package
+ (name "perl-moox-cmd")
+ (version "0.015")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RE/REHSACK/MooX-Cmd-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0145ha8vnc6sbg82ps96wj716bznq2qamm657bia9ji2yxhbnsam"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-capture-tiny" ,perl-capture-tiny)
+ ("perl-list-moreutils" ,perl-list-moreutils)))
+ (propagated-inputs
+ `(("perl-module-pluggable" ,perl-module-pluggable)
+ ("perl-module-runtime" ,perl-module-runtime)
+ ("perl-moo" ,perl-moo)
+ ("perl-package-stash" ,perl-package-stash)
+ ("perl-params-util" ,perl-params-util)
+ ("perl-regexp-common" ,perl-regexp-common)))
+ (home-page "http://search.cpan.org/dist/MooX-Cmd")
+ (synopsis "Giving an easy Moo style way to make command organized CLI apps")
+ (description "This package eases the writing of command line utilities,
+accepting commands and subcommands and so on. These commands can form a tree,
+which is mirrored in the package structure. On invocation, each command along
+the path through the tree (starting from the top-level command through to the
+most specific one) is instantiated.")
+ (license (package-license perl))))
+
(define-public perl-moox-handlesvia
(package
(name "perl-moox-handlesvia")