summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-08-09 19:00:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-14 11:37:08 +0200
commit2fa2179135189a6c0fa9c9f1744a5f0f7284dc0c (patch)
treebaf2c0da986f5a75ba11ac2dd33668bd4c3c75b7 /gnu/packages/perl.scm
parent28fd275cafcd8508a786bacac4d56ef927facbfa (diff)
downloadguix-patches-2fa2179135189a6c0fa9c9f1744a5f0f7284dc0c.tar
guix-patches-2fa2179135189a6c0fa9c9f1744a5f0f7284dc0c.tar.gz
gnu: Add perl-hash-fieldhash.
* gnu/packages/perl.scm (perl-hash-fieldhash): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6a59e6bf86..dcd9640d92 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
@@ -3385,6 +3385,30 @@ objects, which execute a given code block when destroyed, and scoped guards,
which are tied to the scope exit.")
(license (package-license perl))))
+(define-public perl-hash-fieldhash
+ (package
+ (name "perl-hash-fieldhash")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/G/GF/GFUJI/"
+ "Hash-FieldHash-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wg8nzczfxif55j2nbymbhyd25pjy7dqs4bvd6jrcds3ll3mflaw"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-leaktrace" ,perl-test-leaktrace)))
+ (home-page "http://search.cpan.org/dist/Hash-FieldHash")
+ (synopsis "Lightweight field hash for inside-out objects")
+ (description "@code{Hash::FieldHash} provides the field hash mechanism
+which supports the inside-out technique. It is an alternative to
+@code{Hash::Util::FieldHash} with a simpler interface, higher performance, and
+relic support.")
+ (license (package-license perl))))
+
(define-public perl-hash-merge
(package
(name "perl-hash-merge")