summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-10 18:47:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-10 18:47:02 +0100
commit96ab233df7eefd4c868a9e9628b834458e9f18d3 (patch)
treeee28a833f9126245d394bf5b2674c7ced3a3bba8 /gnu/packages/perl.scm
parentb4d7689f9255b93b9ea02e01dc490f1416f77782 (diff)
parenta4de1a651e75c9b9d5e6bdb993f5bd5f74875d49 (diff)
downloadguix-patches-96ab233df7eefd4c868a9e9628b834458e9f18d3.tar
guix-patches-96ab233df7eefd4c868a9e9628b834458e9f18d3.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 23 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1e29ae1cbe..4bf76a3467 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1647,9 +1647,8 @@ It returns to the previous working directory when the object is destroyed.")
(lambda* (#:key outputs #:allow-other-keys)
(copy-recursively "."
(string-append (assoc-ref outputs "out")
- "/plib/perl5/site_perl/"
- ,(package-version perl)
- "/czplib/"))
+ "/lib/perl5/site_perl/"
+ ,(package-version perl)))
#t)))))
(home-page "https://sourceforge.net/projects/czplib/")
(synopsis "Library for genomic analysis")
@@ -1751,6 +1750,27 @@ their argument and produces a string as its result. The string contains Perl
code that, when \"eval\"ed, produces a deep copy of the original arguments.")
(license (package-license perl))))
+(define-public perl-data-dumper
+ (package
+ (name "perl-data-dumper")
+ (version "2.173")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/X/XS/XSAWYERX/"
+ "Data-Dumper-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yknbp86md6mjlhbs1lzz6mals3iyizndgiij58qx61hjfrhhxk9"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Data-Dumper")
+ (synopsis "Convert data structures to strings")
+ (description "Given a list of scalars or reference variables,
+@code{Data::Dumper} writes out their contents in Perl syntax. The references
+can also be objects. The content of each variable is output in a single Perl
+statement. It handles self-referential structures correctly.")
+ (license perl-license)))
+
(define-public perl-data-dumper-concise
(package
(name "perl-data-dumper-concise")